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Warranty and Service Policy
Product Warranty
DATAQ Instruments, Inc. warrants that this hardware will be free from defects in materials and workmanship under 
normal use and service for a period of 1 year from the date of shipment. DATAQ Instruments' obligations under this 
warranty shall not arise until the defective material is shipped freight prepaid to DATAQ Instruments. The only 
responsibility of DATAQ Instruments under this warranty is to repair or replace, at its discretion and on a free of 
charge basis, the defective material.

This warranty does not extend to products that have been repaired or altered by persons other than DATAQ Instru-
ments employees, or products that have been subjected to misuse, neglect, improper installation, or accident.

DATAQ Instruments shall have no liability for incidental or consequential damages of any kind arising out of the 
sale, installation, or use of its products.

Service Policy

1. All products returned to DATAQ Instruments for service, regardless of warranty status, must be on a freight-pre-
paid basis.

2. DATAQ Instruments will repair or replace any defective product within 5 days of its receipt.

3. For in-warranty repairs, DATAQ Instruments will return repaired items to the buyer freight prepaid. Out of war-
ranty repairs will be returned with freight prepaid and added to the service invoice.
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DI–4730 Hardware Manual
1. Introduction
This manual contains information designed to familiarize you with the features and functions of the DI-4730 High 
Voltage data logger and data acquisition system.

Features
The DI-4730 has the following features:

• 8 fixed isolated high voltage (±1000V Full Scale) differential inputs with software-programmable input 
ranges of ±10mV, ±100mV, ±1V, ±10V, ±100V and ±1000V per channel

• 7 digital inputs protected to +30V

• Up to 16-bit measurement resolution (dependent on sample rate)

• Built-in USB, Ethernet, and Power over Ethernet (PoE) interfaces

•  Up to 160 kHz maximum throughput sampling rate

• Adaptable low-pass filter per channel - corner frequency set as a function of sampling rate

• A multi-purpose push-button for WINDAQ remote events and start/stop recording

• Multi-color LED indication for easy notification of device status

• Counter channel.

• Frequency channel.

• Free WinDaq data acquisition recording software. Purchase unlock code WinDaq/Pro for ChannelStretch 
and Stand-alone data recording to removable flash memory.

• Stand-alone option allows the user to configure a recording session through their PC then record data in the 
field to removable flash memory via the USB drive port (without being connected to their PC). Stand-alone 
data logging requires Unlock code to record more than 1 channel to removable flash memory.*

• ChannelStretch™ Technology allows you to sync up to sixteen DI-4730, DI-4108, DI-4208, or DI-4718B 
instruments in any combination with a total throughput of 480kHz or more (requires unlock code for each 
device).*

• Fully documented instrument protocol for programming the device in operating systems other than Win-
dows.*

*WinDaq/Pro required per device to use ChannelStretch™ when using WinDaq software. These restrictions do not 
apply when programming the device yourself. This unlock code is also required to record more than a single channel 
to removable USB thumb drive.

Analog Inputs
The DI-4730 features eight differential channel banana plug inputs located on the front panel for easy connection and 
operation. Gain measurement ranges of  ±10mV, ±100mV, ±1V, ±10V, ±100V and ±1000V are programmable on a 
per channel basis.

Utilize the functionality of WINDAQ software to experience all the features built in to these cost-effective industrial 
units. An Unlock Code is required to synchronize and record multiple units when using WinDaq software. There are 
no restrictions when programming the instruments yourself.
Introduction
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Digital Inputs
The DI-4730 contains seven digital inputs that may be used as a general-purpose digital input or for a specific func-
tion as designated on the device. Digital port D0 may be used for WinDaq Events; Digital port D1 may be used for 
WinDaq remote Start/Stop; Digital port D2 may be used for rate measurements; Digital port D3 may be used for 
counts; Digital ports D4 and D5 are general purpose digital input ports. D6 may be used as an external trigger in 
WinDaq software with the “Use External Clock” preference. Please Note: Digital outputs are not available on this 
device.

Software
All software required to record and playback waveforms is included with the purchase of any DI-4730 data acquisi-
tion system on the included thumb drive or via download at run.dataq.com. Use the WinDaq Dashboard to access 
WinDaq Acquisition software or to setup the stand-alone configuration.

WINDAQ® Recording and Playback Software
WINDAQ Acquisition and WINDAQ Waveform Browser allow you to record and playback data acquired through 
your instrument. WINDAQ software is an invaluable resource to record and analyze your data and is available for 
free from our web site (www.dataq.com).

WINDAQ Data Acquisition software (free) can be used to record waveforms directly and continuously to disk while 
monitoring a real time display of the waveforms on-screen. It operates, displays, and records data in real time when 
connected to your PC. An optional unlock code (WinDaq/Pro) is available to sync multiple units into a single 
WinDaq file.

WINDAQ Waveform Browser playback software (also known as “WWB”) offers an easy way to review and analyze 
acquired waveforms. A built-in data file translator allows the user to display multiple waveforms acquired by 
WINDAQ Acquisition software or any of a wide range of data acquisition packages. The software’s disk-streaming 
design allows data files of any length to be graphically displayed rapidly, in normal or reverse time directions. Seven 
standard cursor-based measurements, frequency domain, and statistical analysis functions help simplify waveform 
analysis and interpretation. WINDAQ Waveform Browser is free and installed when installing WINDAQ Software.

Help
All WINDAQ software utilizes context-sensitive help. Help may be accessed through the Help menu or by pressing 
the F1 key with any pull-down menu item selected. This will take you directly to the Help topic most relevant to that 
particular function or feature. Help topics discuss in detail each function available in the software.
Introduction
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2. Specifications
Analog Inputs
Number of Channels: 8

Channel Configuration: Differential

Measurement range per channel: Programmable ±10mV, ±100mV, ±1V, ±10V, ±100V, ±1000V

Isolation: ±1000V input-to-output and channel-to-channel

Max normal mode voltage (VNM): 800VDC or peak AC

Max common mode voltage (VCM): 1000VDC or peak AC

Max Input without Damage: ±1000VDC or Peak AC (±1000V and ±100V Ranges all other ranges 
with fuse protection)

Common Mode Rejection: 100dB min @ DC to 60Hz

Accuracy: 0.25% of full scale range ±100µV
N.A. for 10mV range

Input Impedance: 10MΩ for all ranges

Analog frequency response (each ch): ±1000, 100, 10, 1V: -3 db @ 5.0 kHz
±100mV: -3 db @ 4.50 kHz

Channel-to-channel crosstalk rejection: -75 dB @100kHz into100 Ω unbalanced

Analog input connector type: Safety banana socket - 1 pair per channel

ADC Characteristics
Resolution: 12- to 16-bit

Above zero ADC counts: 2,047 to 32,767
Below zero ADC counts: 2,048 to 32,768

Max. throughput sample rate: Standard: 160 kHz
Stand-alone: 20 kHz to 160 kHz (dependent on flash memory)

Min. throughput sample rate: Standard: 20 Hz (2.2 samples per hour with WinDaq)
Stand-alone: 0.0017 Hz

Sample rate timing accuracy: 100 ppm

Digital Inputs
Number of Ports: 7

Configuration: Input

Threshold levels: TTL compatible

Absolute maximum applied voltage (V): 25 V dc

Reserved Digital Inputs
Port 1: WINDAQ remote events

Port 2: WINDAQ remote start/stop

Port 3: Rate input

Port 4: Count input
Specifications
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Count/Rate/Digital Inputs
Internal pull-up value: 4.7 k

Input high voltage threshold: 2.4 V

Input low voltage threshold: 0.8 V

Terminal count: 65,535

Maximum rate frequency: 50 KHz with one enabled channel
20 KHz with 2-4 enabled channels
10 KHz with 5-7 enabled channels

Minimum rate frequency: 0.5 Hz

Maximum count frequency: 50 kHz

Ethernet Interface
Type: 10/100Base-T

Connector: RJ-45

Protocol: TCP/IP

Server Type: DHCP or Fixed IP

Removable Memory
Type: MLC, pSLC, or SLC flash memory (with USB SD card reader); USB 

thumb drive

Required Format: FAT32

Indicators and Connections - Rear Panel
USB port: USB 2.0 (mini-B style connector) PC communications

USB Drive (A-type Connector): USB drive for Stand-alone data logging
Cannot be used concurrently with the USB interface

Ethernet port: RJ-45 10/100Base-T; PoE supported

Digital I/O connections: One 16-position screw terminal block

Button: Multi-function control (Start, Stop, Save Configuration, Apply Configu-
ration)

Status LED: One multicolor LED for status indication

Indicators and Connections - Front Panel
Analog Input Connections: 16 insulated banana jacks (2 per channel)

USB ChannelStretch™ Operation
Total Max Units: 16

Max Channel Count: 128 Analog, 112 Digital

Max Throughput: ≥480 kHz (higher speeds may result in data loss)

Channel skew between any 2 units: 10 µS, typical
Specifications
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Synchronization Conditions: Syncs with any combination of DI-4108, DI-4208, DI-4718B, and DI-
4730 USB instruments.
All synced instruments must operate at the same sample rate per channel, 
regardless of channel number, type, or range.
All instruments must be connected to the same USB controller. The use 
of USB hubs are recommended to meet this requirement.

Ethernet ChannelStretch™ Operation
Total Max Units: 16

Max Channel Count: 128 Analog, 112 Digital

Max Throughput: ≥50 kHz (higher speeds may result in data loss)

Channel skew between any 2 units: 100 µS, typical

Synchronization Conditions: Syncs with any combination of DI-4108, DI-4208, DI-4718B, and DI-
4730 Ethernet instruments.
For most accurate synchronization, all instruments should be connected 
to the same Ethernet switch.

Power
Voltage: 9-36 VDC

Power Consumption: 14 Watts

Environmental
Operating Temperature: 0°C to 50°C (32°F to 122°F)

Operating Humidity: 0 to 90% non-condensing

Storage Temperature: -20°C to 60°C (-4°F to 140°F)

Storage Humidity: 0 to 90% non-condensing

Physical Characteristics
Enclosure: Aluminum base with steel wrap-around

Mounting: Desktop; Bracketed

Dimensions:  7.29"W × 9"L × 1.52"H
(18.5D × 22.86W × 3.86H cm.)

Weight: approx 3 lbs

Software Support
WINDAQ software: OS support: Check online at http://www.dataq.com/products/windaq/

windows-compatability/

Programming: Instrument Protocol
Specifications
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3. Installation
The following items are included with each DI-4730 Data Acquisition System. Verify that you have the following:

• A DI-4730 data acquisition instrument.

• 6-foot USB cable.

• 5-foot Ethernet cable.

• AC power supply.

• A DATAQ Instruments screwdriver for digital signal lead connections.

• A USB flash drive with WinDaq software and an NIST-traceable calibration certificate. Can also be used for 
stand-alone data logging.

If an item is missing or damaged, call DATAQ Instruments at 330-668-1444. We will guide you through the appropri-
ate steps for replacing missing or damaged items. Save the original packing material in the unlikely event that your 
unit must, for any reason, be sent back to DATAQ Instruments.

Install WINDAQ Software
All software for the DI-4730 can be installed via a download-able executable directly from the DATAQ Instruments 
web site. The software is also available on the provided USB flash drive.

1. Disconnect all DATAQ Instruments USB devices from your Computer.

2. Plug the USB flash drive (the USB flash drive is shipped installed on the instrument) into your computer’s USB 
port or go to run.dataq.com to download the software.

3. Save the executable (Dataq Software Suite Web Setup.exe) to your local hard drive.

4. Double-click on the executable to extract the program and begin software installation.

5. Follow the on-screen prompts and enter all required information.

6. Software installation is complete - you will now see a “Successful Installation” box - click OK to exit WINDAQ 

Installation.
Installation
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You can now plug the device(s) into your PC. Click on the appropriate program group (specified above — default is 
Start > Programs > WINDAQ) and click on “WinDaq Dashboard” to access WINDAQ software.

Connect the Instrument to Your Computer
All DI-4730 instruments can be installed, configured, and operated as a USB device or an Ethernet/PoE device. The 
WinDaq Dashboard application will automatically detect the communications interface being used.

USB Installation

1 Apply power to the DI-4730.

2. Connect one end of the provided USB cable to the “USB” port on the DI-4730.

3. Connect the other end of the provided USB cable to a USB port on your PC.

4. Open the WinDaq Dashboard application.

The device appears on the list of available devices in the dashboard utility. Run WinDaq Data Acquisition software, 
set the device clock, change ethernet settings, and configure and record data to a thumb drive with the menu items 
available in the dashboard.

Ethernet Installation
All DI-4730 instruments are shipped DHCP-enabled. We recommend you setup a DHCP reservation on your network 
for your data acquisition applications.

1. Find the MAC address of your DI-4730. The device MAC address is printed on the bottom label of the device:

2. Login to your Router and ensure the DHCP server is enabled.

3. Access the DHCP Reservations, Static DHCP, or IP Allocations page/table.

4. Enter the MAC address of your device in the table (you may need to enter colons for proper format - for example, 
001B1000232 may need to be 00:1B:81:00:02:32), enter an unused IP address in the table row (or allow your 
router to select it for you if possible), and Select/Enable for DHCP Reservation.

5. Save your router settings.

6. Connect your DI-4730 unit into your Local Area Network using the supplied Ethernet Cable.

7. Apply Power to the device if required. PoE devices can derive power from a PoE switch.

Open the WinDaq Dashboard utility to access device settings and run WinDaq Data Acquisition software. The 
WinDaq Dashboard allows you to set the device clock, change your Ethernet settings (DHCP/Static), setup and 
record to a thumb drive, access files on the thumb drive, and view live data.
Installation
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If your device is not discovered in WinDaq Dashboard, connect it to your computer via the USB cable and configure 
the Ethernet settings to allow for DHCP.

If the device is available in WinDaq Dashboard but you cannot run WinDaq Acquisition software, you may have the 
application blocked in Windows Firewall. See https://www.dataq.com/blog/data-acquisition-software/is-the-win-
dows-defender-firewall-blocking-windaq/ for more information and resolution.
Installation
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4. Controls, Indicators, and 
Connections
Front Panel
The front panel of the DI-4730 contains 16 banana jacks for safe connection of analog input signals.

Analog Inputs
All analog input signal connections are made to the banana plugs. Each terminal is clearly labeled to correspond with 
the physical channel. Each analog input measures ±10mV, ±100mV, ±1V, ±10V, ±100V or ±1000V (programmable).

+ Input 1:1
with protection

100:1
Attenuator

1:1
with protection

100:1
Attenuator

- Input

Hi+

Lo+

Hi-

Lo-

MUX PGA

Range
Hi/Lo Controller
Controls, Indicators, and Connections
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Use the following diagram to connect Analog Input Channel 1.

Specify a full scale range for the channel in the menu item Edit > Channel Settings.

Scroll through all enabled channels with the Next and Previous buttons.

Low-pass Filter
Each analog channel employs a low-pass filter with automatic corner frequency selection. The filter is a CIC (cas-
caded integrator comb) type that uses as many as 512 samples per channel to calculate in real time as data is acquired. 
Filter response is optimized when sampling frequency is set to ten times the highest frequency of interest.

The DI-4730 calculates its own Last Point, Maximum, Minimum, and Filter data making it available at the program-
ming level. Acquisition methods “RMS” and “Frequency” are permanently disabled for the DI-4730, as are Input 
Types “Nonlinear” and “Thermocouple” and selections for “Unipolar” and “Fahrenheit.”

Please Note: Last Point, Maximum, and Minimum modes utilize only 12-bit data as the CIC filter is not used.

Signal + Signal -
Controls, Indicators, and Connections
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Resolution as a Function of Sample Rate
The resolution of the DI-44730 is a function of sample rate. The lower the sample rate the higher the resolution. ADC 
resolution (R) is a function of selected sample rate per channel (F), and the number of enabled analog channels (C):

C Enabled Channels

1 1

2 2

4 3-4

8 5-8
Controls, Indicators, and Connections
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Rear Panel
The rear panel of the DI-4730 contains power, communications, and digital inputs.

“Digital Inputs”
Refer to the following for Digital Input pinout:

D#: Digital port (0-6). Can also be used for specific WINDAQ functions (+25 Vmax).
D0 Event — WINDAQ Remote Event Marker (or general-purpose) 
D1 Record — WINDAQ Remote Start/Stop (or general-purpose)
D2 Rate — Rate Input (or general-purpose)
D3 Count — Counter Input (or general-purpose)
D4 and D5 — General-purpose digital inputs
D6 Ext Trig — External Trigger (or general-purpose)

Excitation: +15V out. Max current = 67mA. Use these ports to power sensors as required.

“Status” LED
Indicates what mode the instrument is in. Use the chart on the top of the instrument for quick reference. Use the table  
below for a detailed description of each state as well as a description of some states not displayed on the label.

State Mode Description

Connecting The device is looking for a connection to your PC or USB thumb 
drive. It will check the USB interface first, then the Ethernet and USB 
thumb drive. Once a connection is established the device will enter 
Idle mode.Blinking White

Idle

USB Connected

The device is connected to and communicating with your PC through 
the USB port. The USB thumb drive and Ethernet port are not accessi-
ble.

Blinking Green

Idle

Ethernet or USB 
Drive Connected

The device is connected to and communicating with your PC through 
the Ethernet port or the device is in Stand-alone mode. The USB inter-
face is not accessible.

Blinking Green/
Yellow

Acquiring Data

to PC via USB 
Interface

WinDaq Acquisition Software is running and the device is acquiring 
data to your PC via the USB interface.

Blinking Blue

EthernetUSBUSB Drive

Status

Button

Power

D4 D5 D6D3
Count

D2
Rate

D1
Record

D0
Event

Digital Inputs (0 - 25V Max)

Excitation
Controls, Indicators, and Connections
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“USB Drive”
Allows you to record to any USB flash memory device with a USB A type connection. Not all flash memory is fast 
enough to record at higher sample rates. Use the provided USB flash drive for rates below 20,000 S/s Throughput. 
The mini-USB interface cannot be used in conjunction with the USB Drive.

“USB” Mini-B USB Connection
The USB interface port allows you to connect the instrument to your PC via USB cable. When in USB mode the 
Ethernet cable and USB thumb drive are inactive.

“Ethernet” port
The Ethernet interface port allows you to connect the instrument to your PC or network via Ethernet cable. When in 
Ethernet mode the USB connection is inactive. The port supports Power over Ethernet (PoE).

Acquiring Data

to PC via Ethernet 
Interface

WinDaq Acquisition Software is running and the device is acquiring 
data to your PC via the Ethernet interface.

Blinking Blue/
Yellow

Recording Data

to USB thumb 
Drive

The device is acquiring data and recording to your USB thumb drive. 
Do not remove power - power interruption could result in data file cor-
ruption.

Blinking Blue/
Green

Armed

USB thumb Drive 
is waiting for a trig-
ger condition

The device is acquiring data and waiting for a trigger condition to 
begin recording to your USB thumb drive.  Do not remove power or 
the USB thumb drive - either could result in data file corruption.

Blinking Blue/
Cyan

Re-armed

USB thumb Drive 
is waiting for a trig-
ger condition

The device is acquiring data and waiting for another trigger condition 
to continue recording to your USB thumb drive. Do not remove power 
or the USB thumb drive - either could result in data file corruption.

Blinking Blue/
Cyan

Busy

USB thumb Drive 
is busy

The device is reading from or writing to the USB thumb drive. Do not 
remove power or the USB thumb drive - either could result in data file 
corruption.

Blinking Red

Error The device is unable to perform any operations. Cycle power or use 
the control button to resolve the error. 

Solid Red

Button Pushed The LED turns white to indicate the control button is engaged.

Solid White

Idle

USB connected in 
CDC mode

The device is connected to and communicating with your PC through 
the USB port in CDC mode. WinDaq software will not run. The USB 
thumb drive and Ethernet port are not accessible.

Blinking Yellow
Controls, Indicators, and Connections
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Control “Button” Operations
The Control Button can be used to stop or start recording data to the USB thumb drive when using the instrument as a 
stand-alone data logger. The Control Button can also be used to update firmware (contact support for instructions if/
when required). The Control Button can also be used to create an instantaneous event marker when running WINDAQ 
Acquisition software.

Record Data to USB Thumb Drive
Record data to an installed USB thumb drive. The device must be in Idle mode and set for USB Drive (mode LED 
must be flashing Green/Yellow). After the button is pressed, the mode LED will flash Blue/Green or Blue/Cyan to 
indicate it is in a recording mode.

Stop Recording to USB Thumb Drive
Manually stop recording to the USB thumb drive (when the mode LED is flashing Blue/Green, Blue/Cyan, or Blue/
Magenta). After the button is pressed the mode LED will flash Green/Yellow to indicate Idle.

Fix Errors
The Control Button can also be used to fix some common operating errors. When the instrument is in Error mode 
(mode LED is solid red), some action must be taken to fix the error before you can use it. Generally, the Control But-
ton can be used to make the instrument operational again when in Error mode.

Switching between LibUSB and CDC Modes

The native communication mode of DI-4730 instruments is LibUSB but it can be switched to the USB CDC 
(Communication Device Class). CDC mode allows the USB port of DI-4730 devices to appear like a traditional RS-
232 port, which is common across most operating systems and development languages. Please note: LibUSB 
communication is required for WinDaq Acquisition software and programming with our .NET SDK. Only switch to 
CDC mode when writing your own programs at the protocol level (for example, Python applications). Use the 
following sequence to switch your device to/from LibUSB/CDC modes:

1. Connect the device to your PC via the USB port.

2. Apply power to the device.

3. When mode LED stops blinking white and is in Idle mode, push and hold the Control button. This must be com-
pleted within five seconds after the device is in Idle mode.

4. When the mode LED turns red, release the Control button.

5. The Mode LED will flash white then indicate Idle in either LibUSB or CDC mode:

• CDC mode: Blinking Yellow

• LibUSB mode: Blinking Green

Save Ethernet and Stand-alone configuration to Thumb Drive

Save Ethernet settings and/or stand-alone configuration settings using the Control Button. Ethernet and Stand-alone 
configurations can also be saved to the thumb drive via the Dashboard (preferred method). Device must be in Idle 
mode for Ethernet or USB thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for 
your device in order to save the stand-alone configuration.

1. Format your USB thumb drive using your PC.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.
Controls, Indicators, and Connections
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4. Plug the formatted (empty) thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the thumb drive and revert to Idle mode when complete.

Configuration files include network.json (Ethernet configuration) and config.whd or config.whc (WinDaq 
configuration). Use the WinDaq Dashboard to create configuration files.

Apply Ethernet and Stand-alone Configuration to Device

Load Ethernet settings or stand-alone configuration settings using the Control Button. Ethernet and Stand-alone 
configurations can also be applied via the Dashboard (preferred method). Device must be in Idle mode for Ethernet or 
USB thumb Drive (mode LED blinks green/yellow). The Unlock Code must be purchased for your device in order to 
apply the stand-alone configuration.

1. Save configuration files to your USB thumb drive.

2. Confirm device is in Idle mode for USB Flash Drive (mode LED blinks Green/Yellow).

3. Push and hold the Control button.

4. Plug the thumb drive into the device (Drive) while holding the button in.

5. Release the button when the mode LED changes to Red/Black.

6. The device will read and load the configuration files to the device and revert to Idle mode when complete.

Configuration files include network.json (Ethernet configuration) and config.whd or config.whc (WinDaq configura-
tion). Use the WinDaq Dashboard to create configuration files.

Ground Lug

Power Input Jack
Power must be applied with the included power adapter or with an alternate appropriate source (9-36VDC, 15 watts 
max). Alternately you may power the device with a Power over Ethernet (PoE) switch.

Power Switch
Power the DI-4730 on/off using the power switch.

Connecting Digital Input Signal Leads
Connect signal leads to the DI-4730 digital inputs:

1. Insert the stripped end of a signal lead into the desired terminal directly under the screw.

2. Tighten the pressure flap by rotating the screw clockwise with a small screwdriver. Make sure that the pressure 
flap tightens only against the signal wire and not the wire insulation. Do not over-tighten.

This ground lug should always be connected to a solid chassis or earth ground. This connection is man-
datory when connecting signal leads.
Controls, Indicators, and Connections
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3. Tug gently on the signal lead to ensure that it is firmly secured.

When an input signal is connected and WINDAQ Acquisition software is run, WINDAQ’s real time display immedi-
ately reveals the input waveform on your computer’s monitor.

Digital Ports
The DI-4730 contains 7 general-purpose digital input ports. Many of the ports also provide specific functionality in 
WINDAQ or a third-party program.

D0 Event is for WINDAQ Remote Events. This bit inserts an event marker in your data.
D1 Record is for WINDAQ Remote Storage. This bit can be programmed to begin recording data.
D2 Rate is for Rate measurements: 10Hz to 50kHz.
D3 Count is for Counter/Timer measurements up to 65,536.
D4, D5, and D6 are general-purpose digital inputs.

Equivalent Digital Circuit:

Dig In Dx

Dx

10

10K

+5

10K

3.3V
Controls, Indicators, and Connections
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WINDAQ Remote Events (D0 Event)
To use a switch closure or TTL signal to record WINDAQ Event Markers, connect signal leads to the appropriate 
Remote Control Event terminals on the DI-4730 as shown below.

Once the switch closure or TTL signal is connected, activate Remote Events through WINDAQ Acquisition Software. 
Events may be automatically placed on the rising or falling edge of the trigger signal. Use the menu command 
Options > Remote Events + to set WINDAQ to place event markers on low-to-high transitions of the Event input. 
Use the menu command Options > Remote Events - to set WINDAQ to place event markers on high-to-low transi-
tions of the Event input.

Event markers may also be placed in your data file manually by pressing the push button on the instrument. You must 
enable Remote Events in WINDAQ to use the button (use the menu command Options > Remote Events +or Options 
> Remote Events -).

EthernetUSBUSB Drive
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Power

D4 D5 D6D3
Count
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An example event marker in a WINDAQ data file is shown below.

*Please Note: Event Markers do not display in the real-time WINDAQ acquisition software - they only display in the 
WINDAQ playback software (WWB).

WINDAQ Remote Storage (D1 Record)
To use a switch closure or TTL signal to begin recording data remotely, connect signal leads to the appropriate 
Remote Control Record terminals on the DI-4730 as shown below.

EthernetUSBUSB Drive
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Once the switch closure or TTL signal is connected, activate Remote Storage (Record) through WINDAQ Acquisition 
Software. Storage to Disk may be automatically placed on the rising or falling edge of the trigger signal. Use the 
menu command Options > Remote Storage 1 to set WINDAQ to begin recording on low-to-high transitions of the 
Record input. Use the menu command Options > Remote Storage 0 to set WINDAQ to begin recording on high-to-
low transitions of the Record input.

WINDAQ Rate (D2 Rate)
Enable channel 10 to record Rate, or the number of falling-edge transitions per unit of time that are applied to this 
input. Click on Edit > Channels in the WINDAQ Acquisition menu to open the Channel Selection grid. Channel 10 is 
the designated Rate channel. Click on the Channel 10 channel box to enable/disable Rates. The Channel 10 channel 
box will display an “R” when enabled.

Connect any TTL pulse stream (25 VDC max) to the D2 Rate channel on the DI-4730.

Select Channel 10 in the channel display, then select Edit > Channel Settings in the menu to specify a full scale 
range for the Rate channel. Ranges of 10, 20, 50, 100, 200, 500, 1000, 2000, 5000, 10000, 20000, and 50000 Hz are 

EthernetUSBUSB Drive
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available. Choose a range that comes closest to your expected full scale rate or frequency. For example, if you need to 
measure the output of a flow meter that can measure a maximum flow rate of 100 gallons per minute, and the output 
frequency at that rate is 100 Hz, you would choose the 100 Hz range setting. A range setting of 200 Hz full scale sac-
rifices half of the instrument's resolution at 200 gallons per minute, and a range of 50 Hz allows measurements to 
only 50 gallons per minute full scale. 

Check the "Cycles/min" box to display and select frequencies reported in cycles per minute instead of cycles per sec-
ond (the measurement interval remains the same). Tachometer measurements in units of RPM (revolutions per min-
ute) is just one example that benefits from selecting this option. For example, if the 100 Hz range setting is selected 
and "Cycles/min" is checked, the full scale range is actually 6000 cycles per minute.

Please Note: To measure the maximum rate, which is defined as 2 times the Maximum Sample Rate/Channel , the cur-
rent values of Maximum Sample Rate/Channel divided by Sample Rate per Channel MUST be an integer. 

WINDAQ Counter (D3 Count)
Enable channel 11 to record Counts, or the number of falling-edge transitions that are applied to this input. The count 
may be reset via WINDAQ software or under program control as necessary. Click on Edit > Channels in the WINDAQ 
Controls, Indicators, and Connections
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Acquisition menu to open the Channel Selection grid. Channel 11 is the designated Count channel. Click on the 
Channel 11 channel box to enable/disable Counts. The Channel 11 channel box will display a “C” when enabled.

The counter channel accumulates counts over time whether recording or in standby mode as soon as the Counter 
channel is enabled. The accumulated values will be recorded to your data file unless you reset the counts to zero. The 
maximum count value is 65,535 before the counter resets to zero automatically.

Use the Edit > Reset Count command in WINDAQ Acquisition software to reset counts immediately to zero. This 
feature is available in both standby and record modes.

Use the Edit > Preferences > Reset Count on New File Record in WINDAQ Acquisition software to reset the count at 
the start of a new file or when using the Edit > Preferences > Record Next File on Full or Open Next File on Full fea-
ture to reset counts to zero every time a new file is started.

Use the Edit > Preferences > Reset Count on Manual Record in WINDAQ Acquisition software to reset counts to 
zero every time you begin or resume recording a data file using the File > Record command (F4).
Controls, Indicators, and Connections
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Connect any TTL pulse stream (25 VDC max) to the D3 Count channel on the DI-4730.

General Purpose Digital Inputs

Enable Channel 9 for general-purpose digital input functions. Click on Edit > Channels in the WINDAQ Acquisition 
menu to open the Channel Selection grid. Channel 9 is the designated Digital Input channel. Click on the Channel 9 
channel box to enable/disable the digital inputs. The Channel 9 channel box will display an “I” when enabled.

Channel 9 records and displays all the digital inputs, even the state of the Rate and Count inputs if those channels are 
enabled. With Channel 9 selected in the display window click Scaling > Digital Plot to show a digital display and 
make the data more meaningful on screen.
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WinDaq Dashboard
The WinDaq Dashboard allows you to run WinDaq Data Acquisition software, sync the device clock with your PC, 
modify Ethernet settings, configure your instrument for stand-alone data logging to record data to a USB flash drive, 
and access the USB thumb drive via the Ethernet interface. Devices in a ChannelStretch™ Group can synchronize 
data recording in that group. Select all the devices under a ChannelStretch group and click on the Start WinDaq but-
ton. Stand-alone data logging is not available using ChannelStretch.
Controls, Indicators, and Connections
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Use the Configure menu to access the Stand alone setup window.

Select and configure all channels available on your device, select a sampling interval, and setup recording Trigger 
conditions. The Stand alone configuration also allows you to Save/Load configurations via the File menu. Use the 
help file provided in WinDaq Dashboard to learn more. Please Note: You cannot record to the USB thumb drive while 
the device is connected to your computer’s USB port.

ChannelStretch™
Expand the channel count of your DI-4730 with ChannelStretch. Connect up to 16 DI-4730, DI-4718B, DI-4108, 
and/or DI-4208 devices with a powered USB hub (multiple cascaded/connected powered USB hubs can be used) or 
Ethernet switch to record more than 8 channels of data to a single WinDaq file. Synchronized units must use the same 
communications interface to sync. This provides a total of up to 128 analog channels and 112 digital ports at a 
maximum throughput rate of 480 kHz. Cascade multiple USB hubs or Ethernet switches to expand port count. 
Synchronized instruments must have the same sample rate per channel, regardless of channel number, type, or range. 
The WinDaq/Unlock option per instrument is required to synchronize two or more devices when using WinDaq 
software.
Controls, Indicators, and Connections
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Connection

All USB devices must be on the same USB controller (or hub)* in order to synchronize data acquisition. All Ethernet 
devices must be on the same subnet as the PC that is recording the data (preferably the same Ethernet switch). 

*Please Note: Because of the way Windows operating systems manage USB controllers, the only way to be absolutely 
sure you are on the same controller is to use a powered USB hub.

to PC

to Power
as required

USB
 Hub or 
Ethernet 
Switch

16 units max

ChannelStretch™ Technology
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Channel Selection

Devices are listed in the Channel Selection grid in alpha-numeric order of the serial numbers of the device. Devices 
must be connected to the USB hub before starting WinDaq.
Controls, Indicators, and Connections
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5. Unlock WinDaq and Stand-
alone Data Logging
An unlock code is required to record more than a single channel to the USB flash drive or to use ChannelStretch™ to 
synchronize multiple instruments (unlock code required for each unit to be synchronized). Go to https://
www.dataq.com/products/di-4730/ to purchase the unlock code (under Accessories) or call 330-668-1444. Once pur-
chased, you will be given a Key code to enter into WinDaq Data Acquisition software.

Please Note: If you ordered the unlock code with a new device, the device will ship unlocked and this procedure will 
not need to be completed.

1. Start WinDaq Acquisition software.

2. Click the menu item Help > Unlock WinDaq.

3. Enter the Key in the appropriate dialog boxes.

4. Click OK.

Your device is now unlocked for ChannelStretch and stand-alone data logging.
Unlock WinDaq
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6. Dimensional Drawing
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